Recently, I bought a 1979 Mercedes 240d. Enthusiasts refer to this model of Mercedes as the W123. You can learn more about the W123 on Wikipedia

My W123 has 384,000 miles on the odometer. Like many W123s, the odometer is also broken. From the service history and registration information, I figure that the car has right around 400,000 miles. It is on its second engine, which, from what I can tell, has around 140,000 miles on it. It has a four-speed manual transmission, manual windows, a power sliding roof, and air conditioning, which works. It has almost no rust. It has extensive and meticulous service records from the man who owned it for 21 years, and minimal service records since he sold it to its previous owner, in 2006 or so.

This page exists to remind me about the little annoyances that I have with the car so I can fix them. They are ordered by priority. As I fix them, I will post information on how I fixed them so that others may mend their own cars.

W123 log

July 25th, 2010

The fuse for the sunroof motor was missing. This is a convenient reason for the sunroof to not work. I replaced the fuse with one from Autozone, and the sunroof was still inoperative. I will try cleaning the switch next; while the switch is off, I can test to see if it is getting power, which will help me narrow down the cause of the failure.

July 27th, 2010

I discovered that the dome light needs to be replaced, and that the idle adjuster knob on the dashboard is very likely broken. The idle adjuster knob allows you to increase the idle speed to help the car warm up. This is useful for cars that operate in cold climates, and for cars that are behind on routine maintenance like mine; without it, you'll need to give the car a little gas for the first 10-15 seconds, or it will stall. The good news is that the cable is probably something I can pick up at a junkyard (along with said dome light).

I will take it to the mechanic today to get the engine caught up on maintenance. It will definitely get an oil change, a valve adjustment, and fuel filters, and will probably also get a diesel purge, injector service, and other fluids changed as well. Once this is out of the way, it should be fine with regular oil changes and valve adjustments; services that I can perform on my own with the right tools.

July 31st, 2010

The valve adjustment, oil change, and fuel filter change were successful in the sense that the car now starts when cold, and requires no gas to remain idling when cold. This is a marked improvement over its condition when first purchased, and will give me cause to procrastinate on fixing the idle adjuster knob, something that I should definitely do before winter.

I have slowly been working the car into my regular car use. Today, it covered 35 miles without incident (though there is an intermittent noise from the rear differential. Not sure what that would be). The climate control knobs are stiff, but work. The A/C does a good job of cooling the car.

Tomorrow I will try to clean the sunroof switch. I may also get around to topping off the transmission fluid. I'm not sure that it is low (it is a manual transmission, so there's no dipstick for me to check), but reverse is notchy, and second gear grinds occasionally. If it is like other maintenance on this car, it probably hasn't been changed for 5 years, so it is due in any case.

August 2nd, 2010

I have discovered that the hood closes for real if you apply more force to it when closing it.

August 4th, 2010

I will be done with GSoC at the end of next week. After that, I have a week or so before an actual vacation to work on the car. Hopefully I can resolve most of the list down there in that week -- it seems like a lot of stuff, but most of it is little cosmetic things that won't take too long.

I managed to remove the climate control knobs, only to discover that the little plastic cups underneath the knobs are cracked and basically ruined. I also discovered that I don't have a socket large enough to fit around the nuts on the knobs to remove them. Getting the climate control unit out will allow me to replace the bulbs in the center console and test the sunroof switch, both of which are priorities.

Also, I'm going to add door seals to my to-do list. I gather that these are pretty easy, and, since mine are pretty trashed, will make the car quieter.

August 13th, 2010

I've made no progress on the car so far, but I've put probably 250 miles on it since I've purchased it without any issues. It's a very pleasant car to drive, and the working air conditioning is quite nice in the summer.

August 17th, 2010

I finally found time to get the car up in the air today. The flex discs are fine -- the rear one will probably need to be replaced before too long, but had no obvious damage. The front one seemed pretty good. I was worried about them because they weren't explicitly mentioned in the service records anywhere that I could see, and they are wear items, but I guess they were replaced not too long ago. Maybe I'll ask the previous owners if they know anything about them.

August 18th, 2010

I ordered the door seals today, along with a new air filter. While driving to the grocery store with the window open, I smelled diesel. This may mean worn injector return lines, which are a wear item and are easily replaced. Cleaning the engine bay will help reveal leaks, but that (and a car wash) will have to wait until I get the new door seals fitted.

August 21st, 2010

I checked out the injector return lines today. They're dirty, but I can't tell from that if they're leaking. I'll keep an eye on them after I clean the engine bay.

Apparently the car doesn't have front speakers at all in the usual place, and, from what I can tell, never did -- there are these circular dash-like placeholders where speakers should be, but no speakers.

I cleaned the sunroof switch, but the sunroof still doesn't work.

August 27th, 2010

The door seals have been replaced. I used non-Mercedes seals, which fit passably on 3 of the doors. I'm going to want to replace the one on the driver's side rear door soon, and I figure I'll give the others a chance to see if they work without issue. I also washed, clayed, and waxed the car. It cleans up pretty nicely for a 30 year old car.

August 30th, 2010

I drained, flushed, and refilled the coolant system yesterday. While doing that, I also replaced the thermostat and radiator cap. The car now warms up a lot faster (reaching normal operating temperature in a reasonable amount of time), but runs a little hot. Probably I have a bubble in the system that needs to work its way out.

I'm taking the car on a 400 mile road trip tomorrow. Hopefully it will be trouble-free.

September 9th, 2010

I drove the car up to Northern California for a vacation last week. I guess (since the odometer is still broken) that I probably put 1000 miles on the car during the trip.

Right before I left, on the 31st, the glow plug system fuse (an 80-amp strip fuse) blew, melting its holder on its way out. I couldn't find the correct fuse locally, so I temporarily wired an incorrect 80-amp fuse into the circuit, got the car started and warmed up, and then restored the circuit to its fuseless configuration (it would not have been safe to drive with the incorrect fuse, at least installed as I had it installed). The glow system is not necessary when the engine is warm, and the engine would not be off long enough to cool during the drive up, so this fix was sufficient to get me there. I ordered the correct replacement fuse and holder and replaced them later.

Other than that, the car worked without issue. It now pings a bit more than it did before I left, though. I suspect that this is a fuel issue -- perhaps tired injectors (which are at least 40,000 miles overdue for cleaning and testing). I'll remove them and have them tested when I get a chance.

September 16th, 2010

I've replaced the light bulbs in the climate control unit. For a '79 240d with A/C, there are a total of 8 bulbs:

To replace the fiber optic octopus bulb, I removed the A/C control panel; you do this by removing the A/C knob, removing the 24mm nut behind it, and gently removing the panel. If you look down and to the left, you can see the fiber optic octopus. If you have small hands, and move some wires out of the way, you can just fit your hand into the opening you make by removing the panel and replace the bulb. I found an implicit caution against overtightening the 24mm nuts behind the fan, heater, and a/c control knobs in that my car had cracked plastic behind three of those four knobs from overtightening of that nut.

All of the bulbs are the same 1.2W/12V bulbs, part number 2721 on autohausaz. They are $0.69 each. I ordered a bunch of them because they're uncommon in local auto parts stores, and are easily lost.

I noticed that the A/C knob light doesn't seem to work, and that there wasn't a bulb in there at all when I went to replace it. Is this meant to light up? If so, I guess some of the wiring or the socket is damaged.

September 26th, 2010

Today I replaced the old fuel injectors with fuel injectors that had been rebuilt with Monark nozzles.

Lately, the car has nailed under partial throttle (especially when cold), had increasingly difficult cold starts, and a shaky idle. Since the injectors had been in there for 150,000 miles and had never been cleaned, I suspected them. Other common explanations for these symptoms included clogged fuel filters, valves in need of adjustment, and a leaking primer pump (older style primer pumps are prone to leaking, apparently). My car has fairly new fuel filters, a fairly recent valve adjustment, and a new-style primer pump that didn't seem to be leaking. If your car has symptoms similar to mine, and you want to be sure that it is injectors, you can have them tested at an injector shop. If you haven't already taken care of the fuel filters, valve adjustment, or primer pump, and your car has symptoms like mine, you should take care of those items first-- they're much cheaper than new injectors.

While I was in there, I installed new injector return lines. The old ones weren't leaking, but were quite old. The car now idles correctly (even with the A/C on), accelerates more briskly (slightly), and doesn't nail under partial throttle anymore. I'm very happy with the purchase.

If you don't have very many tools, note that there are a couple of cheap tools that will speed things up. To unscrew the hard fuel lines, I used a 17mm flare nut wrench (I guess this is also called a crow's foot); its narrow jaw works well on the injector pump fittings. I also used a 25 inch breaker bar, 10 inch vertical extension, and 1 1/16 inch deep socket to break the old injectors loose. The breaker bar and extension together are $20 or so at Harbor Freight; the injectors get torqued in at 52-59 ft/lbs, so they take a bit of force to get off, and the breaker bar helps you provide that. The socket is $10 at Sears. When in doubt (and if you can), bring an injector with you to the store. You want to make sure whatever socket you use to remove the injectors is capable of fitting over the return line fittings . Some sockets are just not deep enough to do this, and some get much narrower near the top.

October 4th, 2010

Today I learned about the options my car came from the factory with.

This confirms my theory about the car not having a radio from the factory, and also tells me what color interior parts to look for.

The old sunroof switch in the dashboard is pretty faded and pretty ugly, so I bought a new one off eBay this weekend. I also cleaned the inside of the windows (which desperately needed to be cleaned). I need to clean the rest of the interior, now.

October 8th, 2010

I bought a new sunroof switch off of eBay to replace the faded and icky looking one that came with the car. While I was installing it, I tested the old switch with my multimeter (it worked fine), and then discovered that I had put the fuse in wrong for the sunroof motor. With the fuse in correctly, the motor works, though doesn't move the sunroof at all. Probably a stripped gear or something. I aim to have the motor and gearbox out this weekend to figure that part out.

October 23rd, 2010

I disassembled the sunroof motor assembly the other weekend. The transmission is fine; no stripped gears. Good, because it means I don't have to buy new gears, but bad because it means that there isn't an easy answer to the sunroof not working. I really would like to get that open, even if it is just to do a pre-emptive cleaning of the drains.

The rest of the car is still working fine. It rained here for some of last week, and it seems pretty watertight, though the rear window seal allows a small amount of water to leak into the trunk.

The car is noticeably cranky when started from cold. I should really get that cable fixed so I can increase the idle to help it warm up.

November 6th, 2010

I noticed that the heater valve was leaking coolant the other day. This is a coolant distribution...well, valve that is controlled by the heater controls within the car. Turning either the driver or passenger knob moves a cable that opens a valve on the firewall that allows coolant to flow to the heater core (each knob controls its own valve). I replaced that today, along with the upper and lower radiator hoses. I ordered new valve to heater core hoses, but those seemed fine so I didn't replace them. Hopefully I didn't introduce any new leaks while doing that.

December 4th, 2010

I replaced the fast idle cable just before I drove the car up to my parents' house for thanksgiving (necessary, since it's quite cold where they live). This, after some adjusting, is working fine. The car behaved well on the trip, though seems to have a distaste for traveling at more than 60 or so for extended periods of time (causing weird vibrations, rattles, and poor fuel mileage). It is probably best to accept that 55 is the ideal cruising speed, and have a relaxing trip with good fuel economy.

I'm struggling to find a comfortable driving position in this car. In my other car, I sit fairly close to the steering wheel, but that gives me back and leg problems in this car. It feels weird to put the seat farther back, but I'll try that to see if it's any better.

January 9th, 2011

The car stopped glowing last week. I think that the relay (which was already halfway broken) finally broke. I ordered a new one; I was contemplating a fast glow kit, but the current glow plugs seem fine.

I picked up a fresh sunvisor at a junkyard while I was up north over the holidays.

I noticed a very weak spot on the floorpan of the car; under the drivers seat, but not, from what I can tell, at the seat mount. This suggests rust. Further inspection reveals that there is a weird body-colored layer of plastic-backed foam over the entire floor, making rust detection with the naked eye difficult. The rest of the floorpan is not noticeably weak. I'm going to have to take off the foam to get a better look at the floor. If it's a small hole, it should be easy to fix, but I don't want to drive it if there are a bunch of holes in important areas.

March 15th, 2011

The glowing issue was indeed the glow plug relay. The car runs fine with a new one. No other problems to report. I've just purchased some Boston Acoustics S45 speakers for the front of the car.

April 16th, 2011

I can confirm that the Boston Acoustics S45 speakers fit well in the stock speaker location in the front of the car, though you may need to trim off a mounting tab to get them to fit well. The old Alpine radio in my car drives them just fine; YMMV with the stock Becker radio.

I pulled the sunroof headliner out today. Generally speaking, you need to have the sunroof headliner out in order to service the sunroof. An important caveat in my case is that the sunroof generally needs to be opened halfway to easily remove the headliner; mine doesn't move at all under motor power (that's why I want to service it :-). I managed to work it out with the sunroof closed by using a thin (and not too flexible) putty knife. Essentially, you want to carefully push it into the gap between the front of the sunroof and the rest of the roof, and push toward the front of the car. With luck, you'll disengage one of the clips, and you can then work from there to get the rest of them free. From there, it's easy to work with the cable and the slides. I ordered a repair kit with some grease and cleaning tools. Hopefully I'll get to use that next weekend.

July 23rd, 2011

The sunroof ended up getting shelved. I managed to get it apart, I cleaned the slides and other parts of the roof, but couldn't get the cable to go back in. I'm not sure if that means that the tube isn't cleaned properly, or if it's bent, or something else. I'd lost interest at that point, so I just put it back together without the cable. I'll probably revisit that someday.

The car has worked well since then. The brake pad wear light started coming on recently (I wish my other, more modern car had one of those), so I swapped in new front brake pads yesterday. That was pretty painless. While I had the car in the air, I took a look at various wear items. The driveshaft flex discs still look good. One of the rear axle boots has cracked, and has been slowly losing oil. I'll have to replace that soon. Rear axle boots are a common enough failure point on W123s. Since these axles are as old as the car, I'll probably just put in a new axle. It's also about time for a valve adjustment. I'm debating whether to pay my mechanic to do that or to do it myself.

I learned yesterday that the front auxiliary cooling fan actually works. I've never heard it go on before. It's been hot, I guess.

December 21st, 2011

I haven't updated in a while. The car has been running smoothly since the last update, and still gets used regularly. The axle has since lost all of its oil, so that'll need replacing sooner rather than later. I'm debating whether to keep the car, or sell it/donate it to charity. A project car can be fun, and I've certainly had my fun with this project car, but the 240D is much more expensive to keep running than my other car, and my other car is reliable enough that I don't really need a second car.

January 21st, 2012

The driver's side window regulator broke the other day. Who says manual windows are reliable? Well, okay, the part is 32 years old. I was dreading the prospect of buying a replacement, but it turns out that new ones are still made and are actually relatively affordable. No other problems to report.

August 25th, 2012

Nothing too interesting to report. The car still works, and still gets used regularly. It will probably be sold, one way or another, in the next few months to make room for an NB Miata. I don't suppose this has any regular readers, but if you're interested in buying a 240D that's a halfway decent driver, feel free to get in touch.

November 16th, 2012

The 240D is officially sold. Sounds like the new owners are going to make it run on veggie oil. I'm happy that the car is going to a good home.

I've purchased an NB Miata to replace it.

The to-do list (by priority)